Incident Summary – Payment Processing Disruption (Whitelabel Customers)

Incident Report for Ingresso

Resolved

This incident has been resolved.
Posted Apr 14, 2026 - 20:55 BST

Investigating

We are currently investigating this issue.
Posted Apr 14, 2026 - 17:15 BST
This incident affected: White label websites.