Not all dates available to book on iFly
Incident Report for Ingresso
Postmortem

A memory crash issue was spotted on the 1st of September, and our resolution on the 7th solved the memory issue, but created a regression where availability was only being returned for one performance per month. The fix for this (the 13th) seemed to return for the whole month, but actually only returned a week block. It was unclear that this was happening - because it was hard to tell what was normal ifly availability, and what was a put-through error. We knew that something was wrong, but couldn’t see exactly where the error manifested. The week block issue was found and fully fixed on the 21st.

Posted Sep 23, 2021 - 15:16 BST

Resolved
A memory crash issue was spotted on the 1st of September, and our resolution on the 7th solved the memory issue, but created a regression where availability was only being returned for one performance per month. The fix for this (the 13th) seemed to return for the whole month, but actually only returned a week block. It was unclear that this was happening - because it was hard to tell what was normal ifly availability, and what was a put-through error. We knew that something was wrong, but couldn’t see exactly where the error manifested. The week block issue was found and fully fixed on the 21st.
Posted Sep 23, 2021 - 15:15 BST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 22, 2021 - 15:43 BST
Update
We have found the root issue and are testing solutions
Posted Sep 21, 2021 - 08:59 BST
Update
we are continuing to work on a solution to the issue of not all events appearing
Posted Sep 20, 2021 - 16:03 BST
Identified
We're working through some issues with performances appearing and disappearing
Posted Sep 15, 2021 - 15:36 BST
Monitoring
We've deployed a fix a bit earlier and the performances are back. But there's a little bit of housekeeping that we might still need to do for them to appear in the API due to polluted caches.
Posted Sep 13, 2021 - 19:24 BST
Identified
Following on from last week's incident with iFly indoor skydiving sessions being inadvertently taken offline. We've been investigating and have identified a knock-on problem where we are only making one day per calendar month available - the last day of the month.
We believe we have a fix and we look forward to deploying it as soon as we've completed quality checks.
Posted Sep 13, 2021 - 16:44 BST
This incident affected: Supplier connectors.