Intrepid Systems offline
Incident Report for Ingresso
Resolved
This incident has been resolved.
Posted Sep 30, 2022 - 11:42 BST
Identified
Intrepid Sea, Air and Space Museum system offline
Posted Jul 04, 2022 - 15:45 BST
This incident affected: API, White label websites, and Supplier ticketing systems.